Bose QC35 Help Required: Sound Delay Issues

Hi everyone,

I recently purchased QC35s as part of a recent OzBargain deal and thought to come here for some help. I am very impressed by the sound quality and bluetooth connectivity when paired with my Galaxy S7.However, when I connect my headphones to my PC's bluetooth 4.0 dongle (Named: CSR 4.0) I receive a slight sound delay and horrendous background noise such as screeching etc. Has anyone had this issue before and know how to fix it?

TLDR: QC35s work great with S7, works poorly with USB Bluetooth 4.0 Dongle (CSR4.0) - Help Required

Thank you in anticipation.

Kind Regards,

Ben

Comments

  • +3

    Call em up, bose and say u bought from em, they go nothing to do anyway, at the store so boring and sad, let's end on a happy note

  • +5

    maybe invest more than $3 in your usb adaptor

    • -2

      How much more? 50 cents? Total spend would therefore be tree fiddy!

    • According to mr google, S7 got bluetooth 4.2, A2DP, LE, aptX and your $2 got v4.0

  • Get a better adaptor and your issues will be solved.

  • +1

    I had a similar issue. Windows 10 and CSR adapter. Turns out Windows turned the 'mic' on. Open sound panel (right click on the speaker icon in system tray) and click on the recording tab (while connected) and make sure it is disabled. Let us know how you go. Good luck.

    • Didn't work. Might be leaning towards the source being the adapter.

  • I notice you said screeching, it's a USB adapter right and doesn't plug into the 3.5mm port?
    Does it happen when you pair to your phone?

    • -1

      Nope, my headphones work perfectly with my phone. I'm thinking it might be because they're specifically designed for pairing with mobile phones?

      • Not sure why you got neged, I wish the person would comment…
        It works fine with my mac when paired via bluetooth.

        Do you have another computer to test the Bluetooth dongle in?

  • I recently bought one and use them mostly with my Xiaomi MI via Bluetooth. I sometimes get screeching noise too. Usually when I opened many apps in background. Probably those that stream music. When I close all the other apps noise disappears. I would observe this if the multiple apps were causing the issue, else would contact Bose CC.

    Only time I faced delay issue was when I connected it to Projector again via Bluetooth but that could be the dodgy GOT S7E7 torrent quality issue.

    I only get annoyed when in wind headphones picking background noise even though microphone was not activated. Did anyone else face the same issue and find any solution?