Xiaomi Robot 1 Vaccum

Hi,

My xiaomi robot 1 vaccum is not working and giving the error 18 fan malfunction. Anyone else faced the same issues ? I tried opening and removing any possible debris but still doesnt help. I had purchsed via the Gearbite ebay store after reading their post on ozbargain and been over a year so dont think they will cover it under warranty.

Can anyone please advise on how and where to get this fixed ?

Thanks

Comments

  • +1

    I think I had the same issue with mine (it was a bit long ago so I can't remember the error code). It kept notifying me of the error then stopped working altogether. I ordered a replacement motor fan from eBay and it worked like new again.

  • +1

    Two weeks ago, the same problem happened to mine after the robot accessed the shower and got wet. After 2 days, I opened it (YouTube videos, it can be complicated if you don't know what you are doing), cleaned the fan and it worked with a different fan noise and less power for 1h, but then the same error was there again. I've ordered a new fan from Aliexpress (AUD 11 delivered) and will try to replace the fan myself when I have it delivered. I bought the robot in 2017.

    I've also bought a new one (S5 mac) that hasn't been delivered yet so I might end up with two functional robots, or zero, if you are a pessimistic person.

  • +1

    I contacted Gearbite maybe a year ago about the same issue, and noticed they added fan replacement listings to their eBay store shortly after. But I just replaced the fan myself with one from Aliexpress. In hindsight, flicking the existing one to see if it would spin again might have been enough.

  • Given that people seem to know a bit about these in here - does anyone know how to fix the Error 10 cleab or replace filter error? Have replaced filter, cleaned all out, still says it.

    • Error 10 started about 6 months ago and nothing I did, including the obvious replacement of the filter, stopped the message. Even after opening the vacuum to check the fan and cleaning every part, error 10 was still there. As it didn't affect the cleaning, I just ignore.

      • That's what I've done as well - put it as my downstairs vacuum while the new S6?5? (too many models) is upstairs.

  • Does anyone know who to contact for repair ?

  • I had a similar error in mine that related to fan blocked. Can't remember if it was code 18 or 19.

    Anyway. I followed a youtube tutorial on how to open. It didn't take long. Once I got to the fan area, I got a vacuum cleaner there and it sucked out a heap of debris. Put everything back together and it worked. Maybe try vacuuming the fan areas first without opening to see if you get anything.