• expired

Up to 37% Off ECOVACS Robotic Vacuums (e.g. DN79T + Bonus DN622-KTA Accessory Kit $199 Shipped) @ ECOVACS Robotics Amazon AU

50

DEEBOT OZMO 920 $569
DEEBOT OZMO T8 $849
DEEBOT OZMO 950 $799
DEEBOT N79T $199
DEEBOT U2 PRO $409

To receive the Bonus with Purchase discount:
Add all products described in the promotion to your Shopping Basket one of two ways:
a. Via the "Add both to Cart" button in the promotion description, OR
b. Via the "Add to Basket" button on each respective product information page.

The amount will be automatically reduced. The robot vacuum and Bonus Accessory Kits will be sent to you together by Amazon.

Related Stores

Amazon AU
Amazon AU
Marketplace
Ecovacs
Ecovacs

closed Comments

  • +1

    You forgot to mention you have to click the "Add Both to Cart" button to get the free accessory kit / brushes. Buying the vacuum alone does not get you the free accessory.

    • +2

      Yes, I am just going to add it.
      I didn't expect you to help us add such an important point so quickly.
      Warm thanks for your kindness.

  • +1

    Are there any deals available for the auto empty bin by any chance please?

    • Sorry, the Auto-empty bin doesn't join this deal as it will have stock at the end of February.
      You can see our T8+:https://www.amazon.com.au/dp/B08FCQ1Z6Y?ref=myi_title_dp, it contains the Auto-empty bin.
      Thanks

  • Original prices please?

    • I put all deal prices here.
      Which model do you want to know the original price of?
      And If you want to know the original prices of all models, you can click their links to see.

      Thanks

  • I bought a T8 recently and love it. I'm keen to get the Ozmo Pro addon (and the auto empty bin). I remember seeing a $40 off the ozmo pro coupon if you bought the T8 but cant find any reference to it. Any chance I would still be eligible for that?

    • +1

      Yes, the T8 and OZMO Pro purchase together that OZMO Pro can enjoy 40 off. But this promotion ended early.
      Could you please contact us on Amazon? :)

      ECOVACS OZMO Pro for T8/T8 AIVI/T8+:
      http://www.amazon.com.au/dp/B08L23X45Q?ref=myi_title_dp

      The OZMO™ Pro Mopping System enables robots to deal with stubborn stains by using electrically powered high-frequency vibration that works 480/min, and a unique fine mopping mode comparable to an electronic mop.
      1. Larger water tank: 240ml water tank for longer working time
      2. Electronically controlled water pump: precisely control water flow at four different levels to avoid over damping or under damping the cleaning cloth while mopping
      3. Mop detection sensors: automatically turns mopping mode on and off
      4. Bacteria removal: OZMO™ Mopping System can remove over 99% of bacteria based on the test report from a Japanese testing agency
      5. Disposable mopping cloth: It's convenient to use and change the disposable mopping cloth, instead of washing the washable mopping cloth repeatedly

      ECOVACS Auto-Empty Station for T8/T8 AIVI/T8+
      https://www.amazon.com.au/dp/B08FCNVM69?ref=myi_title_dp

      The brand new Auto-Empty Station, liberates your hands up to 30 days
      1) Disposable dust bag large to 2.5L
      2) Dual dust suction channel makes a thorough cleaning
      3) Effectively filter 99% of the particle dust and allergens as small as 2.5µm

      • I am also interested in the pro attachment. Are you selling them discounted?

        • Could you please contact us on Amazon? :)

      • Thanks heaps, have done. In relation to the auto empty station, it is currently OOS, assume I just wait on this one for the update in Feb?

        • Oaky, our customer is replying to you.

          Yes, the auto empty station is still in transit.
          Thanks.

          • @Ecovacs: Hello, our Auto-Empty Station is in stock, please check the link:https://www.amazon.com.au/dp/B08FCNVM69?ref=myi_title_dp
            Thanks.

  • I have Ozmo950. When it works, its really great. but their app sucks big time. 9/10 time it never works, returns data acquisition error and I have to manually to start the cleaning.

    • Sorry to hear that.
      Please tell me the code that will be displayed when the APP reports an error.
      I will ask our after-sales to solve your problem.

      Kindly note that we provide 1 year warranty on the whole machine, and have a local repair center.
      If you have any questions, you also can contact our service center first, contact information as below:
      Tel:1800961314, Monday-Sunday, 9 am to 9 pm(AEDT-Daylight saving time), 8 am to 8 pm(AEST-Regular time)(Public holidays excepted)
      Email: [email protected]

      Thanks,
      ECOVACS team

      • Hi,

        I'm currently facing the same issue. DEEBOT OZMO 920 , not having much luck with support team. Can you please help with this? My robot is still under warranty so I'm not sure what the issue is here.

        Keith

        • Please tell me the code that will be displayed when the APP reports an error. Thanks.

          • @Ecovacs: Hi,

            The robot starts fine but then after a minute or two will stop working (stops in one point, side sweepers still spinning) when i try connect to the app I keep getting data acquisition error. None of the buttons work on the robot. I have sent videos + photos to the support mailbox. Not working for the last 10 days.

            When it worked at the start it was perfect. But now im really dissapointed.

            Keith

            • @keyeat: Could you please tell me the CASE ID that you sent to our support mailbox?
              I will inform our after-sales to check your case. Thanks.

              • @Ecovacs: Case ID : 27498

                Ill update here when gets resolved.

                Thanks
                Keith

                • @keyeat: Okay, I sent your case ID to our after-sales to check and then reply to you.

                • @keyeat: Hello,

                  Our after-sale replied that after checking your problem, our customer service staff suggests arranging a repair service for you.

                  Did you see this email?

                  Thanks,
                  ECOVACS team

                  • @Ecovacs: Hi,

                    No I didnt receive this mail (checked Spam also).

                    Last mail I got was on 1st Feb, I sent followup mail on 3rd Feb.

                    Thanks for checking this.
                    Keith

                  • @Ecovacs: Hi, so I got below mail today.

                    Dear Keith,

                    Good day.

                    We are in the midst of checking with the relevant team. Rest assured that we will update you accordingly.

                    Nothing about suggesting repair. Can you please follow up ?

                    • @keyeat: Okay, I'll follow up and get back to you.

                      • @Ecovacs: Thanks very much for your help!

                        Got it all sorted in the end :-)

  • I recently bought Ozmo T8 AIVI, vacuuming and navigation are great but having issues with mopping-scrubbing function - only using water. Does not dispense water, only dispense when you start the mop function - could be be water pump issue. they're people complaining having similar issues online, so planning to return back.

    • Dear customer,

      This machine has a certain logic for the water output.
      You can observe for a longer time and the water will come out. If the water output is not too large, you can use APP to adjust the water output.
      Under normal circumstances, when the machine is just started, the first few seconds of water is used to wet the cloth. Then there will be no water for about 1 minute, and then continue to water for a few seconds, and so on.

      If you still have questions, please contact us on Amazon.

      Thanks,
      ECOVACS team

      • I used the machine on both low and high water settings with same results, I also tried without the cloth attached to pad to check water flow. escalated to Tech support but they advised the machine need to be checked physically and repair if required as it could be faulty.

  • Just bought a T8 AIVI from their official shop on Amazon, it's pretty good. Everything works fine as I expected.

    Hope they've got customer service as good as their product… mine's still fine though, lol.

  • +1

    hi op - any deal on the T8+ please?

Login or Join to leave a comment