Dishwasher Problems/Buying a New One?

Hi all. Am having trouble with our dishwasher - it will start ok but then stop and have these flashing lights (see pic link below).
Will not initiate wash cycle and has not drained from the last wash cycle.

https://ibb.co/Lrvtx1d

Does anyone know what could be wrong? Is it worth just buying a new one?
If so what is the way to go? Looking at something like this with two different drawers

https://www.thegoodguys.com.au/omega-60cm-double-drawer-dish...

Edit - we don't have manual as it didn't come with the house.
Yeah we're thinking not worth getting someone out.

Any help/recommendations would be very welcome, thank you!

Comments

  • +1

    Most likely the pump - ring the manufacturer for advice

  • +1

    Have you been cleaning the bottom filter regularly. Turn off power at power point in cupboard before doing anything. If you don't have the manual it should be on the manufacturer's website. There might be a clogged outlet. Try youtube search for fixes for your model as well. If all fails call service centre. If its old maybe update looking at a new one. Shop display models may also be an option if you want to save a bit on new.

  • +1

    Does the light flash a specific number of times or in a certain pattern or does it beep in a specific way? If it does then you will be able to at least identify where the fault is using this as diagnostic info.

  • +1

    Firstly clean out the filters and make sure you don’t have little stones or something else in them. Ours was stopping because we were getting grit from the pipes feeding into the dishwasher.

    See what the manual for your dishwasher says,

  • +1

    Turn it off at the wall, unclock the sump in the bottom, reach into the bottom of the sump to make sure the impeller can spin and there is no debris. Also check waste hose isn’t crimped in the cupboard.
    It looks like a really cheap dishwasher from the photo, is it Aldi or Bunnings? If it cost less than $600 I wouldn’t call a service technician as it isn’t worth fixing.

  • Nah doesn't make a noise sadly, just flashes. First day it was like a real low sound. But nothing since. We just moved into this place in May - and house is about three years old. Don't have the manual sadly and there is nothing on Google for Piston - which is strange. So thinking it was just cheap when house was built

    • +1

      Ariston?

  • +1

    I just had a 9 year old bosch finally packup on me, I also inherited it multiple problems ect. I ended buying a Hoover (go figure they make dishwashers) I used appliances online and found it overall a good experience with delivery ect. I picked Hoover for the five year warranty I was gutted Miele didn't have its 10 year any more :/ Just food for thought if buying new, I think Beko has a 5 year promo also on all it's dishwashers. The Hoover seems ok so far, I can't get the wireless to connect yet but it's early days :D

    • I was gutted Miele didn't have its 10 year any more

      I think you'll find they never had it. They claimed '10 or 20 years' of use etc but with our consumer laws, claims like that mean a defacto warranty ;)

    • +1

      It was a one month promotion.

  • +1

    Thanks so much everyone for your responses! Very appreciative. I reckon a new one is in order

  • +1

    Kink in drain hose?

  • https://ibb.co/Lrvtx1d

    That "play" button doesn't work ;)

  • My first Miele dishwasher lasted over 20 years. We only replaced it because it was getting a little noisy and I wanted the lay flat shelf for cutlery instead of the basket. Our Miele appliances have lasted fairly well.

  • +1

    It's definitely drain issue. Had same issue on similar model. Must be food scrap or something stuck at drain hole. Clean it a d it should work.

  • +1

    Disconnect hose where it joins into sink waste pipe, there is most likely a blockage there, or as others have suggested a blockage inside the machine in the drainage area.

Login or Join to leave a comment