• expired

[Backorder] EVGA GeForce GTX 1070 FTW GAMING ACX 3.0 €352.22 (~AU $499) Delivered @ Amazon France

960

Woah this is cheap :) An evga card, so you'll get international warranty. Currently out of stock, so a backorder and will deliver when stock becomes available. Because of this, hopefully these units are manufactured after August and won't have the heating issue.

Check Serial and Request Thermal Pads here if there's an issue

Price History at C CamelCamelCamel.

Related Stores

Amazon FR
Amazon FR

closed Comments

    •  

      That is quite incredible, I have no idea how something like that could have happened.

      •  

        I guess he bought from a different store and not amazon France?

      •  

        Third party seller, not Amazon EU

  • +1 vote

    Yay mine is finally "In preparation" probably wont get it until after xmas but oh well.

  •  

    Don't get it. I purchased mine within 10 minutes of this deal being posted and nothing.

  • +1 vote

    Same here: Finally in preparation and credit card charged. Ordered on Nov 29th.

  • +1 vote

    A nice surprise. Mine is now in preparation [Ordered 7th Dec, awaiting refund for price match]. Have the estimated arrival date on there too

    •  

      That is a nice surprise. Good work! :)

  •  

    "Hello,
    follwoing your email, I would like to inform you that we will ship this article on 23 décembre 2016 as this article will be available on this date."

    I'm starting to wonder if in fact I ordered a completely different card to everyone else lol !
    :)

  • +1 vote

    Just got an update, ordered on the 29th.
    "Delivery within 29 December 16 and Jan. 3. 17"

  •  

    yep just got my confirmation of delivery preparation for delivery in between 26 - 30 december, my card has been charged $501 AUD

  •  

    Got an email this morning, Mine is in preparation.. scheduled to ship 14/12, estimated delivery between 26 and 30 December

  •  

    Has anyone actually received their card yet?

    • +2 votes

      Mine arrived Tuesday - 2 days ago.

      • +3 votes

        did it have the thermal pads applied and BIOS updated already?

        •  

          Not sure - haven't open the box yet. How can I tell? Thanks!

        • +4 votes

          @binnyboy: Just check the serial number with EGVA and it looks like the BIOS and thermal pads already been applied. Here is the message after entering the serial number:

          "Your EVGA Graphics Card already has the recommended VBIOS Update and Thermal Pads applied."

        •  

          @binnyboy: Awesome!!!

        • +1 vote

          Mines at home, arrived today. Will double check mine in about 3 hours when I get home.

      • +1 vote

        Nice! Mine finally left the UK bound for Sydney this morning!!

    •  

      Got mine Friday. Struggled a little bit because fans was not rotating even in Borderlands 2. I was almost under impression that card faulty. However in furmark fans started to work :-)

  • +2 votes

    Botany, Australia 12/16/2016 Import Scan

    Sweet I should have mine early next week.

  •  

    I'm trying to get mine setup now, but i just get no signal on my monitors. Fans and LED's are going though. Using onboard GPU to post this. Will keep Googling. Both 8 pin power connectors are in.

    •  

      Not good to hear! Hope you worked it out.

      •  

        Not yet, spent a few hours on it. Giving up for the night and going to bed.

        The card works when i move it down to the PCIE 4x slot, but not in the 16x slot. In the 16x slot, it's not detected in device manager (if i use onboard video to boot) and doesn't send a signal to my monitor. Lights are on the card though.

        If i put my old 970 card back in the 16x slot, it works.

        I have no idea what is causing it!!

        •  

          well I've given up and am just running it in my 8x PCIE slot, apparently there's almost no difference. I'll put up with this uptil early 2017 when i either upgrade to AMD Zen or an i7.

        •  

          @ynnad:

          Strange that it's doing that.

        •  

          @ynnad: Mine works fine - maybe your motherboard a a little old, give that you have tried everything. I'm currently running a 2011-3 socket motherboard.

        •  

          @ynnad:
          What was your old video card?

        • +1 vote

          @Fatboy74: Nah, it was a GTX 970. I just did a swap over, and Windows 10 auto update the drivers.

        •  

          Yeah I had a 970. I agree that I think it's due to my motherboard being quite old, and it being a compatibility issue, nothing else logical explains it.

          I hope no one else suffers the same issue.

        •  

          @ynnad:

          If it's working in the 8x slot it should work in the 16x slot.
          Double check that it is seated properly in the 16x slot it should kinda click in.

          Double check that this is http://oi68.tinypic.com/2z6bgah.jpg
          sitting properly in between the motherboard and the case.
          I have had a few pci cards that are bent a little and it and it didn't quite go in properly

  • +1 vote

    for those who already received it, who delivered it? auspost or UPS? mine got shipped out with an I-parcel number.

    • +1 vote

      Most likely, UPS will get it to Aus, and Auspost will take over from there, just like the majority of other economy style deliveries.

      •  

        Hope you're right. I had it sent to a parcel locker, most private couriers don't like parcel lockers.

        • +1 vote

          I got mine today. Only sent on the 12th. Took exactly 1 week to get to rural NSW.

          It was sent by UPS and could be tracked via UPS until it got to Australia and then was taken over by a local courier and couldn't be tracked on the UPS website.

        • +1 vote

          @videoman:

          Mines in the country, but Amazon tracking said there was a problem that was resolved, hope it was nothing major.

        •  

          @videoman: nice. Mine got dispatched from Surrey, UK on the 16th

        •  

          @simulacrum: Mine got dispatched on the 15th and still not in the country!!!

        • +2 votes

          @cruzin: Fooooarrrken boastards, so slow!

        • +2 votes

          Just confirming once it got to Australia I got an Auspost tracking number and it was delivered today. Checked the thermal mod page with my serial and have a card with both BIOS/Thermal mods applied. Going to throw it together now and pray to god I don't have a DoA card and then this 5 month ordeal of getting and replacing two of these things will hopefully be over and worth it haha.

        • +1 vote

          @Vand:
          How did it go? Working alright?

        • +1 vote

          @Fatboy74:

          So far so good, got tempts of 48 degrees under load, should find out in the next few days if there's anything immediately wrong with it, otherwise was playing Forza 3 last night maxed out for a few hours and no issues what-so-ever :)!

        •  

          @Vand:

          Epic! Love the temps (my 7970 @ 80ish degrees!).
          Thanks for keeping us updated :)

        •  

          @Fatboy74: Looks like mine arrived in Oz at 5am on 20/12/16. Guessing thats US time. I've got an Auspost tracking number but looks like they haven't received the item from customs yet. Fingers crossed!

        • +1 vote

          @simulacrum:

          Cheers for that. Mine left Surrey on the 16th as well but no updates since. I'm sure mine isn't too far away either :)

        • +1 vote

          @Fatboy74: Yeah hopefully yours was on the next plane out!
          I just got an update from Auspost saying it was processed through their Sunchine, VIC facility at 4:30. They're estimating delivery by tomorrow!

        •  

          @simulacrum:
          Just in time for Christmas :)

        • +2 votes

          Finally got my card… Took too long IMHO!

        • +2 votes

          @cruzin: Picked mine up this morning as well.. it's been sitting on my desk all day taunting me

        • +2 votes

          @simulacrum: Likewise! haha!

        •  

          @cruzin:

          Good to hear you two :)
          Can I ask… once the card arrived in Australia did the tracking update on the amazon.fr page with an Aust Post tracking number?

          Cheers!

        • +2 votes

          @Fatboy74: No, I got the Auspost tracking ID from https://www.i-parcel.com/en/ which uses the tracking ID from Amazon.

        •  

          @cruzin:

          Thanks :)

        • +1 vote

          @Fatboy74: Yep. What cruzin said. Hope you get yours soon!

  •  

    Got my card, did not have the bios update nor pads applied

    •  

      Ouch…

  •  

    mine has finally arrived… unfortunately not already modded.

    •  

      Same here :(, I have updated the bios might get the extra pads or see if Evga will send a replacement.